We are facing issue in ap-south-1 region

Incident Report for Zuper

Postmortem

Root Cause Analysis

  • The incident occurred due to temporary latency between the backend application and the database in the ap-south-1 region.
  • The transient network latency resulted in increased response times and brief performance degradation.
  • The issue resolved automatically within a few minutes without manual intervention.
  • Investigation indicates this was a short-lived connectivity latency issue rather than an application-level defect or infrastructure failure.

Impact

  • Users in the ap-south-1 region experienced degraded performance.
  • API response times were elevated during the incident window.
  • Some requests may have experienced slight delays.
  • No complete service downtime occurred.
  • Total duration of degraded performance: approximately 7 minutes.
  • No data loss was observed.

Resolution

  • Engineering team detected elevated latency through monitoring alerts.
  • Application and database health metrics were reviewed immediately.
  • No infrastructure or configuration anomalies were identified.
  • Latency normalized automatically within a few minutes.
  • Continued monitoring was performed after stabilization to ensure performance returned to baseline levels.

Remediation Items

  • Post-Incident Monitoring: Continue proactive monitoring in the ap-south-1 region to ensure sustained stability.
Posted Mar 03, 2026 - 11:02 UTC

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 05:24 UTC

Monitoring

issue is fixed, we are actively monitoring it
Posted Mar 03, 2026 - 05:18 UTC

Update

We are continuing to investigate this issue.
Posted Mar 03, 2026 - 05:16 UTC

Investigating

We are currently investigating this issue.
Posted Mar 03, 2026 - 05:16 UTC
This incident affected: API - Primary Services.